requirements.rst 1.63 KB
Newer Older
Matt Clarkson's avatar
Matt Clarkson committed
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
.. highlight:: shell

.. _requirements:

===============================================
Requirements for scikit-surgerycore
===============================================

This is the software requirements file for scikit-surgerycore, part of the
SNAPPY project. The requirements listed below should define
what scikit-surgerycore does. Each requirement can be matched to a unit test that
checks whether the requirement is met.

Requirements
~~~~~~~~~~~~
+------------+--------------------------------------------------------+-------------------------------------+
|    ID      |  Description                                           |  Test                               |
+============+========================================================+=====================================+
|    0000    |  Module has a help page                                |  pylint, see                        |
|            |                                                        |  tests/pylint.rc and tox.ini        |
+------------+--------------------------------------------------------+-------------------------------------+
|    0001    |  Functions are documented                              |  pylint, see                        |
|            |                                                        |  tests/pylint.rc and tox.ini        |
+------------+--------------------------------------------------------+-------------------------------------+
|    0002    |  Package has a version number                          |  No test yet, handled by git.       |
+------------+--------------------------------------------------------+-------------------------------------+