Commit 6a351b4d authored by lindawangg's avatar lindawangg

removed unused requirements from eval and inference

parent 2f0aa124
......@@ -17,3 +17,4 @@ export_to_meta.py
model.py
train_tf.py
archive/
requirements.txt
......@@ -42,15 +42,21 @@ If you find our work useful, can cite our paper using:
## Requirements
Install requirements using `pip install -r requirements.txt`
The main requirements are listed below:
* Tested with Tensorflow 1.13 and 1.15
* OpenCV 4.2.0
* Python 3.6
* Numpy
* OpenCV
* Scikit-Learn
* Matplotlib
Additional requirements to generate dataset:
* PyDicom
* Pandas
* Jupyter
## COVIDx Dataset
......@@ -112,7 +118,7 @@ Releasing TF training script from pretrained model soon.
3. To evaluate a tf checkpoint, `python eval.py --weightspath models/COVID-Netv2 --metaname model.meta_eval --ckptname model-2069`
4. For more options and information, `python eval.py --help`
### Step for inference
### Steps for inference
**DISCLAIMER: Do not use this prediction for self-diagnosis. You should check with your local authorities for the latest advice on seeking medical assistance.**
1. Download a model from the [pretrained models section](#pretrained-models)
......
from keras.utils import to_categorical
from sklearn.metrics import confusion_matrix
import numpy as np
import tensorflow as tf
......
from keras.utils import to_categorical
from sklearn.metrics import confusion_matrix
import numpy as np
import tensorflow as tf
import os, argparse
......
absl-py==0.9.0
astor==0.8.1
backcall==0.1.0
bleach==3.1.0
certifi==2019.11.28
chardet==3.0.4
contextlib2==0.5.5
cycler==0.10.0
Cython==0.29.5
decorator==4.3.2
defusedxml==0.5.0
entrypoints==0.3
gast==0.2.2
google-pasta==0.1.8
grpcio==1.26.0
h5py==2.10.0
idna==2.9
imageio==2.6.1
ipykernel==5.1.0
ipython==7.2.0
ipython-genutils==0.2.0
ipywidgets==7.4.2
jedi==0.13.2
Jinja2==2.10
joblib==0.14.1
jsonschema==2.6.0
jupyter==1.0.0
jupyter-client==5.2.4
jupyter-console==6.0.0
jupyter-core==4.4.0
kaggle==1.5.6
Keras==2.3.1
Keras-Applications==1.0.8
Keras-Preprocessing==1.1.0
kiwisolver==1.0.1
lxml==4.3.1
Markdown==3.1.1
MarkupSafe==1.1.0
matplotlib==3.0.2
mistune==0.8.4
nbconvert==5.4.1
nbformat==4.4.0
networkx==2.4
notebook==5.7.4
numpy==1.18.1
opencv-python==4.2.0.32
opt-einsum==3.1.0
pandas==1.0.3
pandocfilters==1.4.2
parso==0.3.3
pexpect==4.6.0
pickleshare==0.7.5
Pillow==5.4.1
pipeline==0.1
prometheus-client==0.5.0
prompt-toolkit==2.0.8
protobuf==3.11.2
ptyprocess==0.6.0
pydicom==1.4.2
Pygments==2.3.1
pyparsing==2.3.1
python-dateutil==2.8.0
python-slugify==4.0.0
pytz==2019.3
PyWavelets==1.1.1
PyYAML==5.1.2
pyzmq==17.1.2
qtconsole==4.4.3
requests==2.23.0
schema==0.7.0
scikit-image==0.16.2
scikit-learn==0.22.2.post1
scipy==1.4.1
Send2Trash==1.5.0
sigopt==5.3.1
six==1.14.0
tensorboard==1.15.0
tensorflow-estimator==1.15.1
tensorflow-gpu==1.15.0
termcolor==1.1.0
terminado==0.8.1
testpath==0.4.2
text-unidecode==1.3
tornado==5.1.1
tqdm==4.43.0
traitlets==4.3.2
urllib3==1.24.3
wcwidth==0.1.7
webencodings==0.5.1
Werkzeug==0.16.1
widgetsnbextension==3.4.2
wrapt==1.11.2
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment